If you guys are experiencing content now appearing like the "Recent Posts" just refresh and it should appear. Sorry for the inconvenience. Also tell your friends about the blog :p .

In 2011

Friday, November 5, 2010

2.1 Flashing For X10i and X10a

Sorry for the delay on the 2.1 post. Like I said before I wanted to wait for a solid method that will work on all X10'a without any bugs. After waiting and reading numerous posts online I am happy to say that the new method   works well. There are 1 or 2 little issues but its not really a big deal. Also this post may be a bit long. For those who already have 2.1, congrats.

Do the following first!!!!
Install your necessary Java Version 32 or 64
Install PC Companion AND run it once
Also if your a Win 7 (and I think vista) user disable  UAC - This is a must
-Reboot your machine!!
Have at least 50% or more battery, I prefer 100%

X10 Files
I used the X10 Global Firmware you can download it here

I am assuming that you have done all the Do the following first!!!! stuff so lets begin.

Step 1
-Download the firmware and extract it to your desktop
-Now in the firmware folder there is a DevID folder choose your OS and run the Device ID program. If that does not work try these methods. Method 1 Method 2
-Now turn off your phone remove the battery and put it back in again, do not turn on your phone

Step 2
-Now open the X10Flash.bat
-Select your OS for me its 32 bit windows 7 so its 3, then hit enter
-Now connect your phone in flash mode. Plug in the mini usb connector to your phone then hold the back button and insert the other end of the wire to your PC. Now in the CMD hit any key.
--Now if you see a bunch of coding lines you are good just wait a while until it says "hit any key to close" or something
--If you get some errors then you did something wrong. You probably have a
  -Not installed the X10 drivers
  -Not installed Java
  -Not followed the first do this steps
  -Wrong Device ID
  -Or commonly a bad usb port. Happened to me so I just changed USB ports and it worked

Step 3
-Now after the flashing is done remove the wire and the take out the battery for a few seconds
-Put it back in and turn on your phone
-Now the initial boot will take a while and you will see the Sony Ericsson and the SE logo and stuff
-Then you will see a camera with a arrow to a phone, your phone is not setting up this will take a while
-After thats done your phone will boot again and you will be presented with the 2.1 SE setup wizard
-After you finish that or skip that your done you have 2.1 : )

--Note
-2.1 is laggy best to go to the root post and delete preinstalled apps that YOU do not need
-For 10a users the 3G will appear as H, do not worry its all the same and it works good
-I would advise you to check out the root post as well

Please comment for any more info, I will try to answer them

6 comments:

  1. does this fix the market problem ?

    ReplyDelete
  2. My x10i is branded to 3uk but I have rooted it.
    Will this still work for me ?

    ReplyDelete
  3. Hello Ahmad, In my case i have no market issues. The market works fine.

    Hello Gary, I believe it should still work. But isn't the 2.1 for UK already released.?

    ReplyDelete
  4. please the link with the firmware again....is broken...

    ReplyDelete
  5. hey use the newer firmware method

    ReplyDelete
  6. can u pls tell me how to change x10a rom to x10i...
    i am using x10a. android v 2.3.3. are there any negative sides of changing rom. i wanna chabge cz i m seeing that x10a is slower than x10i

    ReplyDelete